Маскируем наш роутер в сети провайдера от TTL-фильтра

Советы и подсказки по софту, работе в операционных системах, комплектующих и сборок компьютеров.
Аватара пользователя
toxi
Администратор
Администратор
Articles: 0
Сообщения: 492
Зарегистрирован: 12-04-2008 07:58:25
Ваш пол: Мужской
Имя: Роман
Откуда: Украина, г. Житомир
Контактная информация:

Маскируем наш роутер в сети провайдера от TTL-фильтра

Сообщение toxi »

Теория:
В IPv4 TTL представляет собой восьмиразрядное поле IP-заголовка.
Определяет максимальное количество хопов (hop, то есть прыжок, участок между маршрутизаторами), которые пакет может пройти. Наличие этого параметра не позволяет пакету бесконечно ходить по сети. Каждый маршрутизатор, при маршрутизации должен уменьшать значение TTL на единицу, но некоторые шлюзы можно настроить, чтобы игнорировать это. Пакеты, не достигшие адресата, но время жизни которых стало равно нулю, уничтожаются, а отправителю посылается сообщение ICMP Time Exceeded. Если требуется, чтобы пакет не был маршрутизирован (то есть принят только в своём сегменте), то выставляется TTL=1. На отправке пакетов с разным временем жизни основана трассировка их пути прохождения (traceroute). Максимальное значение TTL=255. Обычное начальное значение TTL=64 (зависит от ОС).
Добавим правило в Mikrotik, что бы с имитировать конечное устройство (для всего роутера):

Код: Выделить всё

/ip firewall mangle add action=change-ttl chain=prerouting new-ttl=increment:1 passthrough=yes
Либо для конкретного исходящего интерфейса:

Код: Выделить всё

/ip firewall mangle add action=change-ttl chain=postrouting new-ttl=increment:1 passthrough=yes out-interface=ether3
Учтите так же то, что это правило супер требовательное к процессору роутера.

Есть вариант сделать так:

Код: Выделить всё

/ip firewall mangle add action=change-ttl chain=postrouting new-ttl=set:64 out-interface=ether3 passthrough=yes
Но в таком варианте трассировка из вашей локалки до любого узла в интернету будет иметь два прыжка - первый ваш роутер, второй конечный узел. Промежуточные узлы не покажутся. Это не всегда удобно.
Читаем "Правила форума", перед созданием сообщения/темы